В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SkriN123
SkriN123
26.04.2020 00:10 •  Информатика

Дан массив целых чисел из 10 элементов поменять местами первый максимальный и последний отрицательный элементы массива. составить программу в паскале

Ответ:
AMAYA000
AMAYA000
05.10.2020 15:23
Var
A:array[1..10] of integer;
i,m,o:integer;

Begin
WriteLn('Введите массив');
For i:= 1 to 10 do
    Begin
    Read(A[i]);
    End;
m:=10;
For i:= 9 downto 1 do
    if A[i]>=A[m] then m:=i;
For i:= 10 downto 1 do
    if A[i]<0 then
    Begin
    o:=i;
    Break
    End;
if o = 0 then WriteLn('Отрицательных чисел нет!')
else
Begin
i:=A[o];
A[o]:=A[m];
A[m]:=i;
For i:= 1 to 10 do
    Write(A[i],' ')
End;
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?