В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Vania54
Vania54
11.02.2022 22:22 •  Информатика

Написать программу, которая вводит массив из n вещественных чисел, а затем заменяет в нём все элементы, превышающие данное число z, этим числом. вывести на экран полученный массив и количество замен. протестировать программу на следующих исходных данных: а) z=10 массив: 1,2 2,6 3 -4,5 11 10,2 3,2 87 -15 б) z=-2 массив: 0 -3,1 11 -7,9 -2,1 -1,9 4

Ответ:
ЮлічкаВдовіна
ЮлічкаВдовіна
05.10.2020 15:10
//PascalABC.Net 3.2
begin
var a:=readARRreal('Вводите: ', readinteger('n ='));
var z:=readreal('z ='); var count:=0;
for var i:=0 to length(a)-1 do if a[i]>z then begin
a[i]:=z;
count+=1;
end;
writeln ('Кол-во замен: ', count);
a.Print;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?