В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Karinka1Malvinka
Karinka1Malvinka
23.05.2023 16:22 •  Информатика

Напишите программу определить кол-во и сумму четных чисел .последовательность чисел оканчивантся 0.программа должна вывести 2 числа ,первое: длину,последовательность ,второе число: сумму четных чисел числа при вводе 4,60,15,0

Ответ:
mariabrin27
mariabrin27
05.10.2020 14:59
Program n1;
var a,k,sum: integer;
begin
readln(a);
k:=0;
sum:=0;
while a<>0 do
begin
if (a mod 2=0) then sum:=sum+a;
k:=k+1;
readln(a);
end;
writeln(k);
writeln(sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?