В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Markys1555
Markys1555
16.03.2023 17:58 •  Информатика

На c++ необходимо написать программу, которая вычислит сумму 2/3+3/4+4/5++n−1n. формат входных данных вводится натуральное число n (3≤n≤105). формат выходных данных программа должна вывести результат вычисления одним вещественным числом с точностью до шести знаков после запятой.

Ответ:
Alinakamisarova
Alinakamisarova
02.08.2020 21:29
#include <iostream>
using namespace std;

int main()
{
    int n;
    double s=0;
    cout << "n = ", cin >> n, cout << "\n";
    for (int i=2; i<n; i++) {
    s += (double)i/(i+1);
    }
    cout.setf(ios::fixed);
    cout.precision(6);
    cout << "s = " << s << "\n";
    return 0;
}

Пример:
n = 10
s = 6.571032
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?