В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
pytbrain2007
pytbrain2007
04.06.2022 07:16 •  Информатика

Напишите программу, которая определяет количество различных символов, встречающихся в символьной строке. входные данные на вход программы подаётся символьная строка. выходные данные программа должна вывести количество различных символов в этой строке. примеры входные данные ab122ab выходные данные 5 pascal abc 1.8

Ответ:
starushka94
starushka94
05.10.2020 14:33
Var used: Set of Char;
    s: string;
    i, cnt: integer;
    c: char;
begin
used := [];
readln(s);

for i := 1 to length(s) do
  include(used, s[i]);

cnt := 0;
for c := #0 to #255 do
  if (c in used) then
    cnt := cnt + 1;

writeln(cnt);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?