Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
selemenevakrist
05.09.2022 20:11 •
Информатика
Дан массив a размера n и целое число k найти сумму последних к элементов
Ответ:
AsanovaLiana
05.10.2020 14:25
Program prog;
Uses crt;
var a: array [1..100] of integer;
n,i, k,s: integer;
begin
clrscr; randomize;
write('N = ');
readln(n);
write('k = ');
readln(k);
for i:=1 to n do
begin
a[i]:= random(50);
write(a[i],' ');
end;
writeln;writeln;
for i:=n downto (n-k+1) do
s:=a[i]+s;
writeln('Sum = ', s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
131756
05.10.2022 19:39
Написать программу которая принимает с клавиатуры 5-значное число а выводит сумму цифр этого числа !...
jkazlova
24.05.2022 12:40
Напишите программу ,! ввести с клавиатуры число,а вывести это же число в одной строчке на 5 больше,в другой в 10 раз больше...
587989nm
28.01.2022 08:59
Алгоритм ребенок-кукла, карта местность, планета глобус...
Vova77723
12.12.2020 04:14
(30 ! ): составить программу на языке паскаль для решения следующей : задать одномерный массив случайным образом, элементы которого принадлежат промежутку [-30; 40]; найти...
Lyudakostina1
28.05.2021 22:52
Program lab1; var x,y: real; begin writeln( введите x ); readln(x); begin if (abs(x) =1) then y: =sqr(x)-1; else if(abs(x) 1) and (abs(x) =2) then y: =2*x-1; else if (abs(x)...
nshxhdnjdbook
21.06.2020 00:48
Нужно перевести в двоичную, восьмеричную, шестнадцатеричную системы числа от 1 до 1000. как это сделать? калькулятором просто невозможно, а говорят что можно как-то формулами...
DimitryPanika
14.06.2021 22:20
Заполнить матрицу 3х3 случайными числами из интервала [0..10] и вторую матрицу 3х3 из интервала [0..5],перемножить таблицы...
zhenyasvetli4n
25.01.2020 23:25
Сократите дроби : 33/44 ; 25/15?...
камилия23
18.09.2020 20:56
Вычисли 1/3+1/8 математика...
Martin45707
29.10.2020 10:58
Л. Н Толстой Кавказский пленник в 5 абзацсе говорится о том что...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Uses crt;
var a: array [1..100] of integer;
n,i, k,s: integer;
begin
clrscr; randomize;
write('N = ');
readln(n);
write('k = ');
readln(k);
for i:=1 to n do
begin
a[i]:= random(50);
write(a[i],' ');
end;
writeln;writeln;
for i:=n downto (n-k+1) do
s:=a[i]+s;
writeln('Sum = ', s);
end.