Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
0224n
29.07.2022 02:24 •
Информатика
Составить программу которая все отрицательные элементы массива удваивает а положительные утраивает.
Ответ:
Max04032003
08.09.2020 22:34
//PascalABC.Net 3.2
begin
var a: array of integer;
setlength(a, readinteger('Введите размерность массива: '));
for var i:=0 to length(a)-1 do
begin
a[i]:=readinteger('Введите элемент: ');
if a[i]<0 then a[i]*=2 else a[i]*=3;
end;
write (a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
akhmetova1
10.01.2021 22:24
Чему равна разность элементов A[4] и A[2] массива, сформированного следующим образом: for i:= 1 to 5 do A[i]:=(i+3)x(i+1)...
fox2121
12.11.2022 01:22
Після якого слова у програмі описуютыся змінні величини?...
Акерке2006
24.10.2022 00:54
Пользователь вводит радиус колеса. Создай программу, которая подсчитает, какое расстояние проходит колесо за 1 оборот, за N оборотов !...
натали19852
09.04.2022 14:31
Яких значень набудуть змінні j та i після обчислення для int j, i = 2 a) j = i++ + ++ib) j = ++i + ++ic) j = i++ + ++id) j = ++i + i--...
ninja2005xxx
23.06.2020 20:01
Нужно написать программу на языке C++. Как вводить и выводить строки я знаю, мне нужны функции, которые находят подстроку в строке и удаляют её. String22. Даны строки S и...
Sabinakerimli
20.01.2020 01:10
У исполнителя Альфа две команды, которым присвоены номера: прибавь 2. умножь на (b - неизвестное натуральное число; b 2 2) Выполняя первую из них, Альфа увеличивает число...
SOFIA0209
24.04.2021 15:32
Какой алгоритм описывается блок-схемой? ...
RFTBOY
14.06.2021 10:22
Написать сатирическое сочинение по картине е. широкова друзья ....
228665123
14.06.2021 10:22
Нужно зделать 1326-1328 с уравнений...
Mamonga
14.06.2021 10:22
Водну упаковку помещается 16 пакетиков рисовой каши достаточно ли 4 таких упаковок, чтобы разместить 65 пакетиков каши? 1) недостаточно, не хватит места для 1 пакетика. 2)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
var a: array of integer;
setlength(a, readinteger('Введите размерность массива: '));
for var i:=0 to length(a)-1 do
begin
a[i]:=readinteger('Введите элемент: ');
if a[i]<0 then a[i]*=2 else a[i]*=3;
end;
write (a);
end.