Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Lera6807
03.05.2022 17:14 •
Информатика
Составить программу, содержащую операторы ввода, вывода, присваивания. 9)найти произведение всех цифр заданного четырехзначного числа.
Ответ:
АринаКузьмичева
05.10.2020 13:25
Program znanija;
var a, res:integer;
begin
res := 1;
write('Введите число: ');
readln(a);
while a>1 do
begin
res := res * (a mod 10);
a := a div 10;
end;
writeln('Произведение всех цифр = ', res);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Manya081505
23.06.2020 04:14
Фокусник высыпает на стол 501 монет достоинством в 1 рубль и предлагает : разложить деньги по девяти кошелькам так, чтобы можно было уплатить любую сумму от 1 рубля до 501...
МилаяРайли06
23.06.2020 04:14
Уодного путешественника не было денег,но была золотая цепочка из семи звеньев.хозяин гостиницы,к которому обратился путешественник с о ночлеге ,согласился держать постояльца...
лариска6
20.12.2020 09:37
Задание 1. В массиве х замените элементы таким образом, чтобы элементы с четными индексами встали на место нечетных и наоборот, и занесите их в массив у. import array as...
bmwm3gtr75
25.12.2020 22:13
Найдите информационный объем (в битах и байтах) растрового изображение размером 20 на 20 пикселей и палитрой из 65 536 цветов...
kostyuchkova12
19.04.2022 19:33
ТОК тему урока «Беспроводные сети» 2) что такое беспроводная сеть3) перечислите преимущества беспроводных сетей4) перечислите недостатки беспроводных сетей5) назовите устройство...
saigafarovatn
06.11.2021 03:23
Мәтіннен жалғау мен шылауды теріп жаз...
Jakai2808
06.11.2021 03:23
Что такое однородные сказуемые?...
Valinka9999
06.11.2021 03:23
Посмотрите на картинку и выберете соответствующие предложения: A) There is a sofa. There are 2 windows. There is an armchair. B) There are a lot of books. There is a lamp....
Badilya1
06.11.2021 03:23
У Айши было 17 яблоки у Ясмина было 45 яблоки сколько яблоки у Айши и у Ясмины...
maria22890
06.11.2021 03:23
Use of English/ Task 4. Read and choose. 1. I hate to wait/waiting. 2. I want to sleep/ slipping. 3. I love to travel/ traveling. 4. I hope to see/ seeing you soon...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var a, res:integer;
begin
res := 1;
write('Введите число: ');
readln(a);
while a>1 do
begin
res := res * (a mod 10);
a := a div 10;
end;
writeln('Произведение всех цифр = ', res);
end.