В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
SamMary
SamMary
24.02.2023 20:14 •  Информатика

Решить на языке python 3.! последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности больше предыдущего элемента. (решение должно быть с циклом while)

Ответ:
hamaturov
hamaturov
05.10.2020 13:16
# coding: utf-8

'''
Последовательность состоит
из натуральных чисел и завершается
числом 0. Определите, сколько
элементов этой последовательности
больше предыдущего элемента.

Python 3.X.
'''

prev = int(input()) # ввод первого элемента
count = 0 # изначально 0 элементов

while True:
    n = int(input()) # ввод числа
    if n == 0:
        break # выход, если 0
    if n > prev:
        count += 1
    prev = n # смещение числа

print(count, "эл.")
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?