В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
liliyana27
liliyana27
19.04.2021 16:00 •  Информатика

Не особо шарю в паскале. нужна . нужно написать программу для определения какой четверти принадлежит точка. мне не нужно решение из интернета, без комментариев и прочего. по возможности с объяснением, а то дальше не вытяну информатику

Ответ:
Бата194
Бата194
05.10.2020 13:18
Var  x,y:integer; 
begin
writeln('Программа определения местонахождения точки');
writeln('Введите координаты точки');
readln(x,y); //вводим координаты точки 
if (x>=0) and (y>=0) then writeln('1 четверть'); //точка принадлежит 1 ч. если обе координаты положительны (это из геометрии)
if (x<0) and (y>=0) then writeln('2 четверть'); //точка принадлежит 2 ч. если х<0, а y неотрицателен (это из геометрии)
if (x<0) and (y<0) then writeln('3 четверть'); //точка принадлежит 3 ч. если обе координаты отрицательны (это из геометрии)
if (x>=0) and (y<0) then writeln('4 четверть'); //точка принадлежит 4 ч. если х неотрицателен, а y<0 (это из геометрии)
end.  
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?