В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
1KateWeg1
1KateWeg1
13.02.2020 17:37 •  Информатика

Написать программу,которая определяет ,что введено с клавиатуры( прописная или строчня буква , прописная или строчная буква ,цифра или символ) написать программу ,которая определяет ,к какой четверти координатной плоскости принадлежит точка. координаты точки вводятся с клавиатуры .написать все эти 2 программы в pascal ) )

Ответ:
saraikinacaterina
saraikinacaterina
05.10.2020 13:09
//1
begin
var ch:=readchar ('Введите символ: ');
if ch in ['A'..'z', 'А'..'я'] then
begin
if upcase(ch)=ch then write ('Прописная ') else write ('Строчная ');
if ch in ['A'..'z'] then write ('английская ') else write ('русская ');
write ('буква');
end
else if ch in ['0'..'9'] then write ('Цифра') else write ('Символ');
end.

//2
begin
var x:=readreal ('Ведите координаты точки: ');
var y:=readreal;
if (x=0) and (y=0) then write ('Точка лежит на начале координат') else
if x=0 then writeln ('Точка лежит на оси ординат') else
if y=0 then writeln ('Точка лежит на оси абсцисс') else
if x>0 then
if y>0 then write (1) else write (4)
else if y>0 then write (2) else write (3);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?