Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Yurgent
11.12.2020 15:46 •
Информатика
Составить программу вычисления функции y=1- при изменении аргумента x в интервале с шагом h=0.1
Ответ:
Mojo228
05.10.2020 12:43
Число повторений цикла = целая часть [(3-0.1)/0.1]+1 = 30
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396
0,0
(0 оценок)
Популярные вопросы: Информатика
Kira1626
13.10.2022 12:22
Впоследовательности из 15 целых чисел определить произведение(p) max и min ,сумму (s) отрицательных чисел данной последовательности...
ppppppp0000
01.05.2023 11:16
Найти шестнадцатеричное число х, которое является решением уравнения 9*x + l = 8*x + n + p , где l - десятичное число 1753, n - шестнадцатеричное число af, p - двоичное число...
6valeria6
01.05.2023 11:16
Перебор размещений из n-элементного множества по k. на с++, питон или паскаль абс...
Gulshatkadilshina
01.05.2023 11:16
Перебор сочетаний из n-элементного множества по k. с++, паскаль абс или питон...
vladamaslanik
01.05.2023 11:16
Перебор размещений n-элементного множества. на с++, питон или паскаль абс...
Ommttika
09.08.2021 09:01
Программа на си++ удалить из массива все элементы равные min(a[1],a[3],…a[2n-1])....
oDESo
05.10.2020 22:51
Рассчитать скорость автомобиля по его тормозному пути для разного покрытия при различных скоростях. свести результаты вычисления в таблицу формула вычисления тормозного пути:...
hopelless2124
02.11.2021 15:49
Решить по информатике: исполнитель вычислитель выполнять только 2 команды: умножать на 2 и прибавлять 1. придумайте для него наиболее короткий план получения из 0 числа 50...
Птичка220903
01.08.2022 13:06
Известно, что некто для шифрования сообщений перед каждой согласной буквы вставляет букву «И», а перед гласной букву «М». Декодируйте зашифрованную информацию: ИММОИНМИИТМОИРМИИНИГ...
vasyazabelin
30.01.2020 09:02
3.Сравните (поставьте знак отношения): 1536 битов и 1,5 килобайта; 1000 битов и 1 килобайт; 8192 байта и 1 Кбайт...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1383 от 09.02.2017
begin
for var i:=1 to 30 do begin
var x:=0.1*(i-1)+0.1; var y:=1-sin(x)/(1-ln(x+0.1));
Writeln(x:3:1,y:15:5)
end
end.
Результат
0.1 0.96174
0.2 0.90986
0.3 0.84579
0.4 0.77000
0.5 0.68267
0.6 0.58380
0.7 0.47331
0.8 0.35102
0.9 0.21667
1.0 0.06988
1.1 -0.08992
1.2 -0.26355
1.3 -0.45217
1.4 -0.65751
1.5 -0.88208
1.6 -1.12960
1.7 -1.40571
1.8 -1.71913
1.9 -2.08389
2.0 -2.52355
2.1 -3.08055
2.2 -3.83866
2.3 -4.98810
2.4 -7.06916
2.5 -12.45227
2.6 -75.39064
2.7 15.42904
2.8 6.17670
2.9 3.42616
3.0 2.07396