В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Эрбол11111
Эрбол11111
06.02.2021 03:05 •  Информатика

Написать программу, которая находит и выводит на печать все четырехзначные числа типа abcd, числа a, b, c, d - различные цифры, для которых выполняется: ab-cd=a+b+c+d на !

Ответ:
лох248
лох248
05.10.2020 12:15
for a in range(1,10):
    for b in range(0,10):
        for c in range(0,10):
            for d in range(0,10):
                if(a != b and b != c and c != d and a != c and b != d & a != d):
                    if(a * b - c * d == a + b + c + d):
                        print(str(a) + str(b) + str(c) + str(d));
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?