Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
Ученица950
18.06.2020 17:18 •
Информатика
Дано двузначное число. определить, кратна ли трем сумма его цифр? ( pascal)
Ответ:
yalex83p0a2c7
05.10.2020 12:14
Если вводится натуральное двузначное число:
var n,s:integer;
begin
write('n = ');
readln(n);
s:=(n div 10)+(n mod 10);
writeln('s = ',s);
if s mod 3 = 0
then writeln('Сумма цифр кратна 3')
else writeln('Сумма цифр не кратна 3');
end.
Пример:
n = 56
s = 11
Сумма цифр не кратна 3
0,0
(0 оценок)
Популярные вопросы: Информатика
urasaya
17.01.2022 17:33
Что делать name = input( введите свое имя: ) age = input( укажите свой возраст: ) print( , + name + ! ) print( тебе уже + age + лет, это ! ) location = input( где вы живете:...
kudryashovaek
10.07.2022 16:18
Как взломать комп училки на информатике 50 ...
Nik93700
11.12.2021 08:59
Написать 10 предложений на тему : техника моей мечты ...
toalexalfaa
13.05.2020 16:23
Делаю тест по информатике на дому сдавать завтро: даны множества а = {1,2,3,4,5,6,7} и в = {4,6,8}. перечислите элементы, образующие следующие множества (записывайте числа в...
nastiia4
29.09.2022 04:19
Укажите правильных порядок действий в алгоритме для получения дополнительного кода целого отрицательного числа. укажите порядок следования всех 3 вариантов ответа: __ прибавить...
otrixx1kiraeee
01.02.2023 05:16
Решите ! символьная строка длиной 100 закодировано при двух алфавитов мощность: первого равна 8, мощность второго 64. определите количество информации в тексте, кодируемом 1...
Zan22
31.08.2022 14:58
Составьте программу рисования узора местоположение робота отмечено ромбом.кр1. 3 использование циклов при создании орнаментов 1 вариант....
оаосов
03.04.2020 17:39
На уроке труда смастерили электронную доску 5*5. после включения через секунду засвечивается центральный квадратик, а через каждую новую секунду засвечиваются квадратики которые...
maximbond04
24.03.2021 18:27
Дан алгоритм в виде блок-схемы. запишите его на алгоритмическом языке....
dfyz2
25.05.2023 17:02
Нужно решить в паскале используя цикл. номер 1 , 2 или 5...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var n,s:integer;
begin
write('n = ');
readln(n);
s:=(n div 10)+(n mod 10);
writeln('s = ',s);
if s mod 3 = 0
then writeln('Сумма цифр кратна 3')
else writeln('Сумма цифр не кратна 3');
end.
Пример:
n = 56
s = 11
Сумма цифр не кратна 3