В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
find1337
find1337
22.01.2023 03:54 •  Информатика

Написать программу в паскале которая будет с массива записывать числа введенные пользователем ⇒ оставлять только те, которые кратны ⇒ считать их среднее арифметическое. максимальное число чисел - 100. ввод чисел заканчивается числом 0.

Ответ:
nadyarn
nadyarn
05.10.2020 11:54
Program n1;
const n=100;
var a: array [1..n] of integer;
i,k,sum,temp: integer;
begin
sum:=0;
k:=0;
for i:=1 to n do
begin
write('введите ',i,' элемент: ');
readln(temp);
if temp=0 then break;
if temp mod 8=0 then
begin
a[i]:=temp;
k:=k+1;
sum:=sum+a[i];
end;
end;
writeln('ср. ариф: ',sum/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?