В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Ррргчг2424
Ррргчг2424
03.05.2023 19:26 •  Информатика

10 класс напишите программу в паскале, которая в последовательности натуральных чисел находит среднее арифметическое трёхзначных чисел или сообщает, что таких чисел нет (выводит no). программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 undefined признак окончания ввода, не входит в последовательность). количество чисел не превышает 100. введённые числа не превышают 300. списанные программы не засчитываю, я тоже умею пользоваться поисковиками

Ответ:
nyto4ek
nyto4ek
02.08.2020 20:49
// PascalABC.NET 3.2, сборка 1381 от 04.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  (var k,var s):=(0,0);
  var m:integer;
  repeat
    Read(m);
    if (m>99) and (m<1000) then begin s+=m; k+=1 end;
  until m=0;
  if k>0 then Writeln(s/k) else Writeln('NO')
end.

Пример
25
6234
193
-46
274
35
0
233.5
0,0(0 оценок)
Ответ:
killpvpglava
killpvpglava
02.08.2020 20:49
Program n1;
const n=100;
var a: array [1..n] of integer;
i,sum,k: integer;
begin
for i:=1 to n do
begin
write('введите ',i,' элемент: ');
readln(a[i]);
if (a[i]=0) or (a[i]>300) then break;
if (a[i]<=300) and (a[i]>99) then
begin
k:=k+1;
sum:=sum+a[i];
end;
end;
if k<>0 then writeln('ср. ариф: ',sum/k)
else writeln('no');
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?