В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
nekit2409
nekit2409
23.07.2022 13:15 •  Информатика

Написать программу в паскале: заполнить двумерный массив n*n случайными числами из интервала [-10,10] и найти сумму элементов меньших элемента стоящего в к-ом столбце и l-ой строке.

Ответ:
Адриана111111111
Адриана111111111
24.04.2020 15:18
// PascalABC.NET 3.2, сборка 1382 от 06.02.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('Количество строк (столбцов) в массиве:');
  Writeln('*** Исходный массив [',n,',',n,'] ***');
  var a:=MatrRandom(n,n,-10,10);
  a.Println(4); Writeln(5*a.ColCount*'-');
  var k,l:integer;
  Write('Введите L,K: '); Read(l,k);
  var lim:=a[l-1,k-1];
  var s:=a.Rows.SelectMany(x->x).Where(x->x<lim).Sum;
  Writeln('Искомая сумма равна ',s)
end.

Пример
Количество строк (столбцов) в массиве: 6
*** Исходный массив [6,6] ***
  -4  -8  -7  -3  -6  -4
   2  -9   1   9  -6   6
  -9  -2  -8  -3  -1  -4
  -1  -9  -3  -7   3  -3
   5   9  -6   8  -1 -10
  -1  -1  -5  -8  -9   4

Введите L,K: 2 3
Искомая сумма равна -138
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?