В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
IgnatBakaev
IgnatBakaev
16.05.2022 21:42 •  Информатика

Напишите программу, которая вычисляет факториал натурального числа n ( 1 ≤ n ≤ 10000 ), сохранив все значащие цифры. факториалом называется произведение всех натуральных чисел от 1 до n : n ! = 1·2· ( n - 1)· n .

Ответ:
Qween123452003
Qween123452003
05.10.2020 10:12
Program n1;
var
n, i: integer;
p: real;
begin
write('Введите n: ');
readln(n);
if (n>=1) and (n<=10000) then
begin
p := 1;
for i := 2 to n do
p := p * i;
writeln(n, '! = ', p);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?