В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ленок216
ленок216
15.06.2020 21:32 •  Информатика

Написать программу по информатике в виде теста должны предлагаться вопросы с примерами , например 6*7=? нужно написать ответ и если правильно , то в конце выходит какой-то комментарий ( молодец! ) , а если наоборот , то например "не правильно. ответ: " и выводится правильный ответ . желательно , чтобы этот тест состоял из 5 примеров , а в конце оценивался например 5 правильных ответов , значит 5, 4 правильных-4 и так далее

Ответ:
ksenkalow4nhp
ksenkalow4nhp
05.10.2020 10:02
Program test;
var ans,k,a,i,b: integer;
begin
randomize;
k:=0;
for i:=1 to 5 do
begin
a:=random(10)+1;
b:=random(10)+1;
writeln(i,' пример: ');
write(a,'*',b,'=');
readln(ans);
if ans=a*b then
begin
writeln('верно');
k:=k+1;
end
else
writeln('неверно, ответ: ',a*b);
end;
write('правильно ',k,' из 5, ваша оценка: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?