В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
igorzarubin2006
igorzarubin2006
14.12.2020 21:37 •  Информатика

Напишите программу на языке паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3.программа получает на выход целые числа. количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не входит в последовательность ).количество чисел не превышает 20. введенные числа [-30; 30]. программа должна вывести одно число: количество четных чисел, кратных 3. буду признательна!

Ответ:
Lraaq
Lraaq
14.08.2020 18:16
Program n1;
const n=20;
var a: array [1..n] of integer;
i,k: integer;
begin
k:=0;
for i:=1 to n do
begin
write('введите ',i,' число: ');
readln(a[i]);
if (a[i]=0) or (a[i]<=-30) or (a[i]>=30) then break;
if (a[i] mod 2=0) and (a[i] mod 3=0) then k:=k+1;
end;
writeln('количество: ',k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?