В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Mollи
Mollи
17.12.2022 10:53 •  Информатика

Нужно решить на языке паскаль. изучаем string. 1.вовочка скучая на уроке придумал себе игру. он открывал книгу на любой странице. выделял фрагмент текста, загадывал символ и подсчитывал сколько раз эта буква встречалась в фрагменте. составить программу, которая подсчитывает, сколько раз загаданная буква встречается в строке. 2.вася пупкин плохо писал диктанты. чаще всего вася писал двойные буквы. ваше написать программу которая удалит из текста повторяющиеся символы.

Ответ:
serovv751
serovv751
20.08.2020 13:13
//PascalABC.NET 3.2 сборка 1318

//1

Var 
 s:string;
  c:char;
  counter:integer;
begin
readln(s);
readln(c);
while pos(c,s)<>0 do
  begin
    inc(counter);
    delete(s,pos(c,s),1);
  end;
writeln(counter);
end.

Пример ввода:
banana
a
Пример вывода:
3

//2

Var
  s:string;
  i:integer;
begin
readln(s);
i:=2;
while i<=length(s) do
if s[i-1]=s[i] then
 delete(s,i,1)
 else
 inc(i);
writeln(s);
end.

Пример ввода:
saad
Пример вывода:
sad
0,0(0 оценок)
Ответ:
viloxy
viloxy
20.08.2020 13:13
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var c:=ReadlnChar('Буква:');
  Writeln('Буква встречается ',s.Where(p->p=c).Count,' раз(а)')
end.

Пример
Текст: а роза упала на лапу азора
Буква: а
Буква встречается 8 раз(а)

// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Текст:');
  var m:=s.MatchValues('(\w)\1{1}').Distinct;
  foreach var cc in m do s:=s.Replace(cc,cc[1]);
  s.Println
end.

Пример
Текст: стеклянный оловянный длинношеее искусство
стекляный оловяный длиношее искуство
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?