В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
котя1995
котя1995
05.08.2021 17:12 •  Информатика

Нужно решить на языке паскаль. изучаем string. 1.дана строка. написать программу, выводящую сумму порядковых номеров заданного символа. 2.дано предложение состоящее из заглавных букв. в предложении только одно слово в котором 3 буквы. вам нужно написать программу которая найдет это слово и выведет его в файл.

Ответ:
Katykpoper
Katykpoper
26.08.2020 07:55
//PascalABC.NET 3.2 сборка 1318

Var
  s:string;
  c:char;
  sum,i:integer;
begin
readln(s);
readln(c);
for i:=1 to length(s) do
if s[i]=c then sum+=i;
writeln(sum);
end.

Пример ввода:
konichiva
i
Пример вывода:
11

//2
Var
  f:text;
  s:string;
  i:integer;
begin
readln(s);
var ars:=s.Split;
i:=0;
while ars[i].Length<>3 do
inc(i);
assign(f,'output.txt');
rewrite(f);
write(f,ars[i]);
close(f);
end.
  
Пример ввода:
ARK DRIVE FINISH
Пример вывода в файл output.txt:
ARK
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?