В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
bagauridiana
bagauridiana
03.06.2022 01:53 •  Информатика

Напишите программу, заполняющую массив из 45 элементов случайными числами от 0 до 34, выводящую полученный массив на экран, прозврдящую поиск элементов, делящихся на 3, подсчитывающую их количество (с выводом на экран) и считающая среднее арифметическое таких элементов

Ответ:
azino776
azino776
05.10.2020 09:09
Program n1;
const n=10;
var a: array [1..n] of integer;
i,sum,k: integer;
begin
randomize;
for i:=1 to n do
begin
a[i]:=random(34);
write(a[i],' ');
end;
writeln;
sum:=0;
k:=0;
for i:=1 to n do if a[i] mod 3 = 0 then
begin
k:=k+1;
sum:=sum +a[i];
end;
writeln('кол-во: ',k);
writeln('сумма: ',sum);
writeln('ср. арифм: ',sum/k);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?