Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
julliastripa
04.05.2020 23:41 •
Информатика
Создать массив а из 10 целых чисел, принадлежащих промежутка (-50; 50). вывести полученный массив на экран. подсчитать сумму положительных и количество отрицательных элементов массива.
Ответ:
DarKerThanBlaCK34
05.10.2020 07:45
//прога на Pascal`e
var
a : array[1..10] of shortint;
i: byte;
count1, count2 : integer;
begin
randomize;
write ('Сформированный массив: ');
for i:=1 to 10 do begin
a[i]:=random (99)-49;
write (a[i], '; ');
if a[i]>0 then inc(count1, a[i]) else inc(count2, 1);
end;
writeln ();
writeln ('Сумма положительных элементов: ',count1);
write ('Кол-во отрицатедьных элементов : ', count2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
roldugina78
07.05.2020 03:32
5) Операционная система осуществляет управление … (выбрать не менее двух вариантов) 1. оперативной памятью 2. местом на дисках 3. печатью текста 4. созданием рисунков...
OksaNatop04
07.08.2021 02:44
№ 1. Под носителем информации понимают: 1) линии связи для передачи информации; 2) параметры физического процесса произвольной природы, интерпретирующиеся как информа¬ционные...
enotowi4enot
29.06.2020 03:06
Написать программу. которая вводит массив из n целых чисел и выводит на экран элементы с чётными номерами....
777vvv
10.12.2020 21:44
4 Мбайт = сколько байт 2,5 Гбайт = сколько Кбайт 8 Мбайт = сколько байт 1,5 Гбайт = сколько Кбайт 1/4 Кбайт = сколько битРешите нужно. Заранее...
АлинаКовтун
31.03.2023 10:53
5. Соотнеси десятичные числа с их двоичными эквивалентами: 1) 3 а) 111 2) 5 6) 1000 3) 2 4) 8 г) 101 5) 7 B) 11 Д) 10 Быстра...
Babai7777
17.03.2021 23:08
1. Даны два целых числа: A, B. Проверить истинность высказывания: «Каждое из чисел A и B нечетное» 2. Дано целое положительное число. Проверить истинность высказывания: «Данное...
Sheva031
08.02.2023 08:42
1. Одноклассники работают с текстом. Данил сохранил текстовый файл в 8-битной кодировке КОИ-8, а Костя сохранил этот же файл в 16-битной кодировке Unicode. В кодировке КОИ-8...
serikovaaida
17.05.2022 21:18
Рассмотри ситуацию: Адиль в приложении «Калькулятор» складывает числа 5 и 2. Проанализируй и восстанови предложенную последовательность шагов работы процессора....
tim2003np0acpp
22.05.2023 12:28
A 6.1. Замените дробью степень с целым отрицательным показателем:1) 7-3; 2) 13-2; 3) 11-1, 4) 12-3; 5) 16-3;...
VaYfL
24.02.2022 17:49
озаглавьте текст,вы пишите слова с пропущенными гласными в корне.Обозначьте изученную орфограмму,т.е.:1) подчеркните её одной чертой ;2) выделите корень ; 3) поставьте ударение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a : array[1..10] of shortint;
i: byte;
count1, count2 : integer;
begin
randomize;
write ('Сформированный массив: ');
for i:=1 to 10 do begin
a[i]:=random (99)-49;
write (a[i], '; ');
if a[i]>0 then inc(count1, a[i]) else inc(count2, 1);
end;
writeln ();
writeln ('Сумма положительных элементов: ',count1);
write ('Кол-во отрицатедьных элементов : ', count2);
end.