В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Stanislava153
Stanislava153
27.02.2020 11:36 •  Информатика

Написать программу,которая проверяет,есть ли во введённом с клавиатуры массиве элементы с одинаковым значением

Ответ:
Kseniaghl
Kseniaghl
26.08.2020 07:27
// PascalABC.NET 3.2, сборка 1379 от 21.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrInteger('Вводите:',ReadInteger('n='));
  if a.Count>a.ToHashSet.Count then
    Writeln('Есть одинаковые элементы')
  else Writeln('Все элементы различны')
end.

Примеры
n= 4
Вводите: 4 2 5 2
Есть одинаковые элементы

n= 4
Вводите: 5 8 -3 0
Все элементы различны
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?