В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
misterbory
misterbory
07.10.2022 13:46 •  Информатика

Задано натуральное число n. напишите программу, которая выведет на экран все числа от 1 до n в обратном порядке. входные данные задано натуральное число n, не превосходящее 1000 выходные данные должны быть выведены в строку n натуральных чисел, разделенные пробелами. в моей программе почему то выводится: 2 1 2 как избавиться от второй двойки после единицы?

Ответ:
ХозяинНосочков
ХозяинНосочков
05.10.2020 06:58
Program z2;  Var n,i:integer; Begin  Write('N = '); readln(n);  while n>0 do  begin    write(n,'  ');    n:=n-1;  end;End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?