В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
alek09
alek09
02.06.2021 23:03 •  Информатика

Написать программу для определения количества и суммы только положительных чисел из 3, введенных с клавиатуры

Ответ:
sofika121
sofika121
05.10.2020 06:55
Var a:array[1..3] of integer;
i,sum,col:integer;
begin
sum:=0;
col:=0;
for i:=1 to 3 do readln(a[i]);
for i:=1 to 3 do
if a[i]>0 then
begin
col:=col+1;
sum:=sum+a[i];
end;
writeln('Сумма: ',sum);
writeln('Кол-во: ',col);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?