Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
123fafafartgd
17.02.2020 06:30 •
Информатика
Программу на языке паскаль через boolean для решения следущей задаси: определить, имеется ли среди чисел a,b,c хотя бы одна пара взаимно противоположных чисел.
Ответ:
SobolVitalik
05.10.2020 06:55
Var a,b,c:integer; l:boolean;
begin
writeln('a, b, c:');
readln(a,b,c);
l:=(a=-b)or(a=-c)or(b=-c);
if l then writeln('Yes') else writeln('No');
end.
Пример:
a, b, c:
5 8 -5
Yes
0,0
(0 оценок)
Популярные вопросы: Информатика
roma34569
16.08.2022 23:03
Вводится последовательность целых чисел до нулевого элемента. Найти сумму чётных элементов этой последовательности....
annarom1108
05.01.2023 00:12
Составить программу вычисления среднего арифметического первых 50 чисел много...
Айlosss
04.01.2021 09:53
Вясельной группе 11 деток любят манную кашу, 13 – гречневую и 7 малышей – перловую. четверо любят и манную, и гречневую, 3 – манную и перловую, 6- гречневую и перловую, а...
dimabolnygin
31.01.2021 22:32
На двумерный массив в pascal! в группе учится n студентов, студенты получили по четыре отметки за экзамен. определить количество неуспевающих студентов и средний группы....
Stanislav69
03.07.2021 09:39
Наведи приклады різних макетів слайдів...
alenaefremova79
09.08.2021 17:00
Дано натуральное число: найти две первые цифры числа. верно ли, что первая цифра данного числа-четная? решение в паскале,...
ЕлизаветаСиянко
09.08.2021 17:00
Решить . поменять местами первую и последнюю цифру натурального числа. решение в паскале. тема while, repeat. подробно, понятно...
katyasha0504
22.12.2022 16:46
Нет гайки нет трактора. когда так говарят?...
azimjonsafu1995
03.09.2021 03:13
Where is new zealand situated? 2. what city is the capital of new zealand? 3. what languages do people in new zealand speak? 4. what is the official language in new zealand?...
ExDragon
03.09.2021 03:13
Плоский контур площадью 4 см2 с индуктивностью 8 мгн и с сопротивлением 2 ом находится в однородном магнитном поле с индукцией 0,2 тл, линии магнитной индукции которого перпендикулярны...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
begin
writeln('a, b, c:');
readln(a,b,c);
l:=(a=-b)or(a=-c)or(b=-c);
if l then writeln('Yes') else writeln('No');
end.
Пример:
a, b, c:
5 8 -5
Yes