В
Все
Г
Геометрия
Д
Другие предметы
У
Українська література
Э
Экономика
Г
География
О
ОБЖ
М
Математика
Л
Литература
Х
Химия
Қ
Қазақ тiлi
М
МХК
О
Обществознание
У
Українська мова
А
Алгебра
А
Английский язык
Ф
Физика
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
Р
Русский язык
О
Окружающий мир
GORH8
GORH8
28.04.2022 18:48 •  Информатика

Составить программу и блок-схему для решения нижеследующих . решение каждой сопроводить пояснительной запиской с описанием используемых в конструкций языка си. y[12] вычислить среднее положительных элементов массива y yi - целые числа

Ответ:
biyubiyu
biyubiyu
14.08.2020 17:21
#include <stdio.h>

int main(void) {
    int Y[12];
    long int mult = 1;
    
    for (int i = 0; i < 12; i++) {
        printf("\nY[%d]=", i);
        scanf("%d", &Y[i]);
    }
    
    for (int i = 0; i < 12; i++) {
        mult *= Y[i];
    }
    
    printf("\n%f", pow(mult, 1.0/12));
    return 0;
}

Функция scanf() является процедурой ввода общего назначения, считывающей данные из пото­ка stdin. Она может считывать данные всех базовых типов и автоматически конвертировать их в нужный внутренний формат. Если бы printf() выполняла ввод, а не вывод, ее можно было бы назвать аналогом scanf().

Функция printf() записывает в stdout аргументы из списка arg-list под управлением строки, на которую указывает аргумент format.

Функция pow() возвращает значение base, возведенное в степень ехр, т. е. baseexp. Переполнение вызывает ошибку области значений. Также может возникнуть ошибка области определения.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?