В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
RedGirl12
RedGirl12
16.12.2022 07:19 •  Информатика

1)составить программу, определяющую на какую букву заканчивается предложение. 2) определить длину 2 слова в предложении

Ответ:
Myrasami
Myrasami
24.04.2020 04:00
Var s: string;
    k: integer;
begin
  write('строка: ');  readln(s);
  writeln('строка заканчивается на букву ','"',s[length(s)],'"');
  k:=pos(' ',s);
  if k=0 then 
  begin
    writeln('в строке одно слово');
    exit;
  end;
  delete(s,1,k);
  k:=pos(' ',s);
  write('длина второго слова: ');
  if k=0 then writeln(length(s))
  else writeln(k-1);
end.

строка: это строка для проверки
строка заканчивается на букву "и"
длина второго слова: 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?