В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
averinatatka
averinatatka
13.04.2020 01:46 •  Информатика

Написать программу, которая - вводит в компьютер с клавиатуры годовые оценки к учеников класса; - подсчитывает и выводит на экран среднюю оценку в классе; - подсчитывает и выводит на экран количество учеников, у которых оценка выше средней.

Ответ:
KEKSIK13317
KEKSIK13317
05.10.2020 05:24
// PascalABC.NET 3.2, сборка 1377 от 19.01.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('k=');
  var a:=ReadArrInteger('Вводите оценки:',k);
  var m:=a.Average;
  Writeln('Средняя оценка по классу: ',m:4:2);
  Writeln('Учеников с оценкой выше средней: ',a.Where(x->x>m).Count)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?