В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
vanuaevstifeev
vanuaevstifeev
16.01.2023 16:51 •  Информатика

Программа получает на вход количество спортсменов, затем программа получает время в секундах, программа выводит среднее арифметическое всех спортсменов

Ответ:
Улька9Пулька
Улька9Пулька
24.04.2020 02:20
C++
#include<iostream>
int main(){
#pragma warning(disable:4996);
#ifdef _DEBUG
freopen("input.txt","r",stdin);
freopen("output.txt","w", stdout);
#endif
int a,v[10000],b,c,s=0;
scanf("%d",&a);
for(c=0;c<a;c++){
scanf("%d",&b);
s+=b;
}
printf("%d",s/a);
return 0;
}
10 тысяч спортсменов, время не более 1e9 сек у каждого.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?