В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
mayorova4
mayorova4
18.10.2021 09:51 •  Информатика

Написать программу которая запросит длинны трёх сторон треугольника. проверить возможность его сущ. и в предположенном результате найдёт и выведет на экран площадь один кто !

Ответ:
Malvina1903
Malvina1903
05.10.2020 04:05
Var  
a,b,c{длины сторон}, S{площадь тр.}, p{полупериметр}:double;
begin
writeln('Введите стороны треугольника:');
readln(a,b,c);
     if (a>=b+c) or (b>=a+c) or (c>=a+b) then     
     writeln ('Такого треугольника не существует')     
     else begin   
     p:=(a+b+c)/2;     
     S:=sqrt(p*(p-a)*(p-b)*(p-c)); {вычисляем S тр. по формуле Герона}     
     writeln ('Такой треугольник существует, его S = ', S, 'ед.');     
     end;     
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?