В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
19nadoeloikat1niki
19nadoeloikat1niki
04.03.2021 14:03 •  Информатика

Дан целочисленный массив размера n, заполненный целыми числами не превышающими 104. необходимо получить два новых массива: в первом массиве должны быть собраны только четные числа, а во втором - нечетные числа. порядок следования элементов в новых массивах не нарушать. формат ввода в первой строке входного файла записано целое число n - размер массива (1 ⩽ n ⩽ 1000). во второй строке записано n целых чисел через пробел, не превышающих 104. формат вывода

Ответ:
Polina19051
Polina19051
08.09.2020 19:20
// PascalABC.NET 3.2, сборка 1374 от 10.01.2017
// Внимание! Если программа не работает, обновите версию!

procedure PrintArr(f:Text; a:array of integer);
begin
  foreach var x in a do Write(f,x,' ');
  Writeln(f)
end;

begin
  var fin:=OpenRead('input.txt');
  var n:=ReadlnInteger(fin);
  var a:=new integer[n];
  for var i:=0 to n-1 do Read(fin,a[i]);
  var fout:=OpenWrite('output.txt');
  fin.Close;
  PrintArr(fout,a);
  var b:=a.Where(x->x.IsEven).ToArray;
  PrintArr(fout,b);
  var c:=a.Where(x->x.IsOdd).ToArray;
  PrintArr(fout,c);
  fout.Close
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?