Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
vova25051
10.08.2020 03:34 •
Информатика
Впрограмме паскаль составить программу даны 2 числа . если числа больше 10,то уменьшить их в 10 раз , то есть оставить без изменений.
Ответ:
nataliylitvino
05.10.2020 02:47
1. Если каждое число рассматриваем как самостоятельное
var
a,b:real;
begin
Write('Введите два числа через пробел: ');
Read(a,b);
if a>10 then a:=a/10;
if b>10 then b:=b/10;
Writeln(a,' ',b)
end.
2. Если оба числа рассматриваем совместно
var
a,b:real;
begin
Write('Введите два числа через пробел: ');
Read(a,b);
if (a>10) and (b>10) then begin a:=a/10; b:=b/10 end;
Writeln(a,' ',b)
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Лера99100
26.03.2020 07:41
Текст занимает полных 7 страниц. на каждой странице размещается 30 строк по 70 символов в строке. какой объем оперативной памяти (в байтах) займет этот текст?...
sofa286
03.09.2021 23:18
Написать программу, которая задает массив из 5 чисел, которые вводит пользователь, а затем выводит на экран эти числа, возведенные в куб...
Настя040827
03.09.2021 23:18
Программа которая будет складывать переменную а с числом 3. при этом пока сумма будет меньше чем 25 требуется увеличить переменную а на одну еденицу в каждом цикле...
nastya2736
03.09.2021 23:18
Учитель задал как открыть инкогнито режим на компьютере. информатика...
Znanija1821
22.02.2023 22:24
Дано целое число n. найти сумму 1+1÷3²++1÷3^n....
Delikmarkomer
17.08.2020 10:30
Для какого из указанных значений числа b истинно высказывание ((b 2) v (b 1)) & ((b 5) v (b 3)) ?...
morgacheva2001
10.09.2021 17:23
Как называется вся информация, накопленная человечеством в процессе его существования? 1)знания 2)память 3)информационные ресурсы 4)познавательные ресурсы...
kirilenkok1
10.09.2021 17:23
Написать программу для вычисления y по формуле: y=x2+1, где x изменяется на промежутке от 0,3 до 1, 7 с шагом 0,2....
yaam13
16.09.2022 13:53
Нужно набрать в чертежнике (кумир) цифры 0, 4, 5, 6 желательно что бы все цифры были симметричны и с одинаковым расстоянием заранее ....
taniabelkova
02.06.2020 21:39
Установи соответствие с видом информации: картина - это аизуальная или обонятельная или вкусовая или таксичная илиаудиальная...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
var
a,b:real;
begin
Write('Введите два числа через пробел: ');
Read(a,b);
if a>10 then a:=a/10;
if b>10 then b:=b/10;
Writeln(a,' ',b)
end.
2. Если оба числа рассматриваем совместно
var
a,b:real;
begin
Write('Введите два числа через пробел: ');
Read(a,b);
if (a>10) and (b>10) then begin a:=a/10; b:=b/10 end;
Writeln(a,' ',b)
end.