В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
arzushka75
arzushka75
24.10.2022 08:23 •  Информатика

Написать программу печати чисел фибоначчи от 1 до 1000, являющихся простыми числами, а также их порядковых номеров в ряду фибоначчи. с программой на паскале .

Ответ:
viper998
viper998
05.10.2020 01:45
Var f1,f2,s:longint; k:integer;
function prost(n:longint):boolean;
var j,m:integer;
begin
m:=0;
for j:=2 to trunc(sqrt(n)) do
 if n mod j = 0 then inc(m);
prost:=m=0;
end;
begin
f1:=1; f2:=1;
writeln('№ - Число');
writeln('1 - ',f1);
s:=1; k:=2;
while s<=1000 do
 begin
 if prost(s) then writeln(k,' - ',s);
 inc(k);
 s:=f1+f2;
 f1:=f2;
 f2:=s;
 end;
end.

Результат:
№ - Число
1 - 1
2 - 1
3 - 2
4 - 3
5 - 5
7 - 13
11 - 89
13 - 233
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?