В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
таиса10
таиса10
14.12.2020 08:29 •  Информатика

Напишите программу в паскале: удалить из массива последний четный элемент

Ответ:
mironmashstem
mironmashstem
05.10.2020 01:43
//PascalABC.NET 3.2 сборка 1318

Const
  n=5;

  Var
  ar:array[1..n] of integer;
  i,indf:integer;
begin
indf:=-1;
for i:=1 to n do
  begin
    readln(ar[i]);
    if not(odd(ar[i])) then indf:=i;
  end;
if indf=-1 then
  writeln('Нет чётных')
 else
  begin
    for i:=indf to n-1 do
      ar[i]:=ar[i+1];
    for i:=1 to n-1 do
      write(ar[i]:4);
  end;
end.

Пример ввода:
1 2 3 4 5
Пример вывода:
1 2 3 5
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?