В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
4ae444ka
4ae444ka
20.06.2021 05:07 •  Информатика

Всоставить программу в которой значение каждого элемента массива равно раннее введённому значению минус порядковый номер

Ответ:
tata535268
tata535268
05.10.2020 00:40
// PascalABC.NET 3.2, сборка 1367 от 20.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  var a:=ReadArrInteger('Вводите элементы массива:',n);
  a:=a.Select((x,i)->x-i-1).ToArray; a.Println
end.

Пример
n= 7
Вводите элементы массива: -12 4 0 -7 9 18 3
-13 2 -3 -11 4 12 -4

Всоставить программу в которой значение каждого элемента массива равно раннее введённому значению ми
0,0(0 оценок)
Ответ:
katyar980
katyar980
05.10.2020 00:40
program zadacha;vara: array[1..10] of integer;i,n: integer;beginfor i:=1 to 10 do read(a[i]);writeln();for i:=1 to 10 do begina[i]:=a[i]-i;write(a[i]:6);end;end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?