В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
NastyaZayatc12
NastyaZayatc12
01.02.2023 16:32 •  Информатика

Нужно написать программу вычисления объёма усеченной пирамиды , в паскаль . v=h(sосн1+sосн2+корень(sосн1 sосн2))/3 . в паскаль

Ответ:
LinkolnPark1
LinkolnPark1
05.10.2020 00:16
Var
  h,s1,s2,v:real;
begin
  Write('Площадь нижнего основания пирамиды: '); Read(s1);
  Write('Площадь верхнего основания пирамиды: '); Read(s2);
  Write('Высота пирамиды: '); Read(h);
  v:=h*(s1+s2+sqrt(s1*s2))/3;
  Writeln('Объем пирамиды: ',v)
end.

Пример
Площадь нижнего основания пирамиды: 28
Площадь верхнего основания пирамиды: 17.5
Высота пирамиды: 9
Объем пирамиды: 202.907830863536
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?