Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
aliyenneqi
31.08.2021 11:04 •
Информатика
1) составить программу, которая из слова "информация" составляет слова "форма","цифра","фирма" 2) составить программу, которая заменяет в тексте, заданном с клавиатуры все буквы "о" на букву "т"
Ответ:
svetlanaGB
09.08.2020 14:30
ОТДЕЛ Задание+;
ИСПОЛЬЗУЕТ Приём;
ПЕР
слово1, слово2, слово3, слово4, слово5: РЯД 50 ИЗ ЗНАК;
сч: ЦЕЛ;
УКАЗ
СПИСАТЬ("информация", слово1);
ОТ сч := 2 ДО 6 ВЫП
слово2[сч - 2] := слово1[сч]
КОН;
слово2[5] := 0X;
слово3[0] := слово1[7];
слово3[1] := слово1[8];
слово3[2] := слово1[2];
слово3[3] := слово1[4];
слово3[4] := слово1[6];
слово3[5] := 0X;
слово4[0] := слово1[2];
слово4[1] := слово1[0];
слово4[2] := слово1[4];
слово4[3] := слово1[5];
слово4[4] := слово1[6];
слово4[5] := 0X;
Приём.Строка(слово5);
ОТ сч := 0 ДО ДЛИНА(слово5) - 1 ВЫП
ЕСЛИ слово5[сч] = "о" ТО слово5[сч] := "т"
КОН
КОН Задание.
0,0
(0 оценок)
Популярные вопросы: Информатика
lublubkoba
10.09.2020 17:27
1)представьте числа в поле из 1 слова: а)-89 б)+57 2) представьте числа в поле из 2 слова: а)0,00000013 б)-800000000...
урааа28
23.04.2022 19:29
Дан файл содержащий сведения о книгах (фамилия автора, название, год издания). найти названия книг данного автора, изданных с 1960 г....
Mockov
26.07.2022 21:17
Традиционно файловые архивы предназначенные для общего доступа пользователей размещаются на...
Аліна02012003
15.08.2022 01:52
X2-ln(1+x)-3=0 как написать на языке pascal?...
MaМа
05.09.2021 14:48
За сколько секунд можно передать текст (объем текста получили в выше), если скорость канала связи равна 14400 бит с...
pilotprofix
15.09.2020 04:10
Хелп ми дана программа на языке паскаль: program a2; var a, b, с, min: real; begin writeln ( введите три числа ); readln (a, b, с); min : = а; if b if c writeln ( min= ,min) end....
KARYCY798
10.10.2020 09:07
Информатика. 7 класс. на фотографии....
mala0661371462ozqf21
23.04.2022 20:34
Напишите алгоритмы, под которых робот, начальное положение которого отмечено *, закрасит отмеченные на рисунках клетки. при разработке алгоритмов используйте цикл с заданным числом...
katea001
14.07.2022 06:22
Рассчитай объём видеопамяти, необходимой для хранения графического изображения, занимающего весь экран монитора с разрешением 720×348 и палитрой из 16777216 цветов....
ника2735
14.07.2022 06:22
Программисты форума, ! может ли в цикл предусловия while быть втиснут for? (pascal turbo)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
ИСПОЛЬЗУЕТ Приём;
ПЕР
слово1, слово2, слово3, слово4, слово5: РЯД 50 ИЗ ЗНАК;
сч: ЦЕЛ;
УКАЗ
СПИСАТЬ("информация", слово1);
ОТ сч := 2 ДО 6 ВЫП
слово2[сч - 2] := слово1[сч]
КОН;
слово2[5] := 0X;
слово3[0] := слово1[7];
слово3[1] := слово1[8];
слово3[2] := слово1[2];
слово3[3] := слово1[4];
слово3[4] := слово1[6];
слово3[5] := 0X;
слово4[0] := слово1[2];
слово4[1] := слово1[0];
слово4[2] := слово1[4];
слово4[3] := слово1[5];
слово4[4] := слово1[6];
слово4[5] := 0X;
Приём.Строка(слово5);
ОТ сч := 0 ДО ДЛИНА(слово5) - 1 ВЫП
ЕСЛИ слово5[сч] = "о" ТО слово5[сч] := "т"
КОН
КОН Задание.