В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
2499930
2499930
24.10.2022 23:27 •  Информатика

Pascal, цикл для, составить программу. 2)составить программу, запрашивающую пароль пользователя. в случае правильности пароля выводится фраза: “можно приступать к работе». если пароль 3 раза введен неверно, то вывести «вызываю охрану»

Ответ:
GDI1
GDI1
04.10.2020 23:43
Var pass,s:string; k:integer;
begin
pass:='12345';
k:=0;
repeat
writeln('Введите пароль:');
readln(s);
k:=k+1;
until (s=pass)or(k=3);
if s=pass
 then writeln('Можно приступать к работе')
 else writeln('Вызываю охрану');
end.

Пример:
Введите пароль:
1
Введите пароль:
12345
Можно приступать к работе
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?