В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
ogh30662
ogh30662
11.11.2020 10:58 •  Информатика

Вгороде bykhovtown требуются программисты. для того, чтобы вакансии с наибольшей заработной платой не остались не востребованными, мэр города составил таблицу, содержащую данные о номере фирмы и заработной плате. так как данные в таблице не найти самую высокую зарплату не так уж и просто. напишите программу, которая выберет для вас лучшую вакансию. входные данные: в первой строке входного файла записано единственное число n, 1< =n< =300000, определяющее количество вакансий. во второй строке, через пробел записаны зарплаты фирм (числа от 1 до 65000). выходные данные: в единственную строку выходного файла необходимо вывести наибольшую заработную плату в списке. входные данные: 5 23 45 12 45000 3200 выходные данные: 45000

Ответ:
кувшинкаВейВей
кувшинкаВейВей
04.10.2020 22:37
Var i,k, max, N: integer;
a: array[1..300000] of integer;
Begin
read(N);
for i:=1 to N do
read(a[i]);
max := a[1];
for i := 2 to N do
if a[i]>max then begin
max:= a[i];
end;
write(max);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?