В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
tolikbn85
tolikbn85
02.10.2020 21:18 •  Информатика

Написать программу в паскаль.для произвольной матрицы строку с наибольшей суммой элементов переписать в обратном порядке программа.

Ответ:
zadrotovg
zadrotovg
04.10.2020 22:27
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! В других версиях языка работа не гарантируется!

begin
  var m:=ReadInteger('Количество строк в массиве:');
  var n:=ReadInteger('Количество столбцов в массиве:');
  Writeln('*** Исходный массив A[',m,',',n,'] ***');
  var a:=MatrRandom(m,n,-50,50);
  a.Println(4);
  Writeln(4*a.ColCount*'-');
  var k:=a.Rows.Select(x->x.Aggregate(0,(x,y)->x+y)).ToArray.IndexMax;
  for var j:=0 to (n-1) div 2 do Swap(a[k,j],a[k,n-1-j]);
  a.Println(4)
end.

Пример
Количество строк в массиве: 4
Количество столбцов в массиве: 5
*** Исходный массив A[4,5] ***
  29  36 -50  -4 -32
  -1 -10  -7 -47 -50
 -16   4  48 -41 -43
   8  46  45  14 -44

  29  36 -50  -4 -32
  -1 -10  -7 -47 -50
 -16   4  48 -41 -43
 -44  14  45  46   8
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?