Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
chukovsema
26.06.2022 07:29 •
Информатика
Составить программу, которая определяет, принадлежит ли заданное число отрезку [0; 2]. на языке pascal, pascalabc.net
Ответ:
neriman04
04.10.2020 22:25
1. PascalABC.NET
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var x:=ReadReal('Введите число:');
Writeln((x>=0) and (x<=2)?'Да':'Нет')
end.
Пример
Введите число: 1.17
Да
2. На этой же версии в стиле традиционного школьного паскаля
var
x:real;
begin
Write('Введите число: '); Read(x);
if (x>=0) and (x<=2) then Writeln('Да')
else Writeln('Нет')
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Waleri2579
08.08.2021 05:19
1.Дан одномерный целочисленный массив А, состоящий из N элементов, N - заданное натуральное число. Элемент Ai (i=1,2,3…, N) назовем особыми, если он больше суммы остальных...
rostikstorozhev
05.09.2022 05:34
Приведите определение информационной модели и сопоставьте его с определением модели данных!...
Chakachoco
12.01.2023 20:13
З якою метою людина планує свою діяльність?...
bika20679
03.07.2020 16:45
Правила майбутньої власної гри...
Mамикс
13.04.2022 16:05
7. Вычислите значение функции ПАМАГИТЕ...
gabbasovilas
25.09.2022 19:12
.Ввести одномірний масив А з n елементів та виконати наступні дії: Знайти максимальний за модулем елемент та поміняти його місцями з останнім елементом масиву....
gr3ygo0se
18.04.2021 00:13
Расскажите все команды сервера ссд пленет, ...
alexalevdorovic
28.02.2020 05:23
Выдели примеры, в которых отображаются действия над информацией. (Может быть несколько правильных вариантов ответа!) посадка картошки приготовление яичницы перевод с русского...
2004080111
26.01.2022 05:34
Определите значение переменной a после выполнения фрагмента алгоритма при а=0 и ф=17 Ввод а Если а 5 то а:=а+20 иначе а:=а*10 Всё ответ: при а = 0 значение переменной а=?...
sie27
29.01.2022 22:19
Якою командою можна відкрити вікно повідомлень...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var x:=ReadReal('Введите число:');
Writeln((x>=0) and (x<=2)?'Да':'Нет')
end.
Пример
Введите число: 1.17
Да
2. На этой же версии в стиле традиционного школьного паскаля
var
x:real;
begin
Write('Введите число: '); Read(x);
if (x>=0) and (x<=2) then Writeln('Да')
else Writeln('Нет')
end.