В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
моллск
моллск
10.11.2021 00:57 •  Информатика

По (9класс) pascal abc а)составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит сумму эелементов с чётными и количиство элементов с нечётными значениями. б)составьте программу, которая заполняет массив a[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит сумму элементов с нечётными и количиство элементов с чётными значениями. в)составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с чётными значениями. г)составьте программу, которая заполняет массив b[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с нечётными значениями.

Ответ:
Ваниш20
Ваниш20
08.09.2020 16:52
На самом деле я пишу на С++, но я думаю ты легко переведёшь это на паскаль.
В а случае мы просто проходимся по циклу, а потом проверяем на корректность. Т.е:
Пускай у нас есть массив arr размером 10.
Тогда:
for (int i = 0; i < 10; ++i) {arr[i]=rand(1,10);}
После этого включаем счётчик c
int c=0;
Ну и проходимся опять.
for (int i = 0; i < 10; ++i) {
if(i%2==0 && arr[i]%2==1) {c += arr[i];}
}

По такому принципу работают и другие случаи, просто меняется проверка в цикле а также что мы прибавляем к с (1 или arr[i]):
б) i%2==1 && arr[i]%2==0; c+= arr[i];
в) arr[i]%2==0; c++;
г) arr[i]%2==1; c++;

Если полностью программа, то это примерно так (для случая в):
int main() {
int arr[10]; int c = 0;
for (int i = 0; i < 10; ++i) arr[i] = rand(1,10);
for (int i = 0; i < 10; ++i) {
if(arr[i] % 2 == 0) c++;
}
cout << c;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?