Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
lenapelevina0
14.12.2020 12:34 •
Информатика
Составьте программу на языке паскаль для определения количества цифр в записи произвольного натурального числа. ( оператор while)
Ответ:
митгпош
04.10.2020 21:50
Var
n, c: longint;
begin
c := 0;
readln(n);
while (n > 0) do
begin
n := n div 10;
c := c + 1;
end;
write(c);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
katasinicina39
02.01.2022 05:49
Для решения с14 петя составил алгоритм и записал программу. петин младший брат олег удалил несколько крманд. определите, сколько команд удалил олег. восстановите программу, которую...
alenazakhar2000al
30.06.2022 00:11
50 ! объясните код , надо блок схему сделать по немучто там отвечает за если, условие и т.д. заранее огромное вам за ! ...
DastyMilk
10.07.2021 08:55
Файл объемом 3000 байт был передан за 1 мин. Определите пропускную сети. Запишите решение и ответ в бит/с...
КристинаСоболева
09.08.2021 06:10
Составьте крассворд на тему использования окон 10 вопросов и 10 ответов...
mrsdyy
16.05.2020 03:27
ответьте на вопросы! один вариант ответа) 1.прежде, чем написать программу, надо: 1) включить компьютер. 2)собрать данные 3)составить алгоритм 2.исключи лишнее: 1)photoshop 2) corel...
AdelinaArMi
30.07.2022 02:58
Любое натуральное число можно представить в виде суммы нескольких последовательных натуральных чисел. Например, число 25 можно представить в виде суммы из одного (25), двух (12+13)...
csonzdanova
12.05.2022 04:06
Почему в слове испытание пишется буква с?...
andreweeoneoff
12.05.2022 04:06
Гриби як і тварини за живлення 3-4 речення...
nadia182
12.05.2022 04:06
Во Что вы понимаете под словом «природа»?2. Как человек пользуется природой?3. Какими могут быть последствия от воздей-ствия человека на природу?4. Почему редкие виды животных и...
Siiii
12.03.2021 19:31
Составить предложение с пассивным залогом: 1) Her wallet (steal) last week 2) It is morning and all the emails (already/send). 3) The new CCTV camera (instal) next week....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
n, c: longint;
begin
c := 0;
readln(n);
while (n > 0) do
begin
n := n div 10;
c := c + 1;
end;
write(c);
end.