Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
kolesnik23
03.09.2021 09:46 •
Информатика
Дан массив состоящий из 8 вещественных чисел. все элементы с чётными номерами уменьшить на 1 с нечетными- увеличить 1
Ответ:
maks200206
31.08.2020 16:26
// PascalABC.NET 3.2, сборка 1361 от 12.12.2016
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandomReal(ReadInteger('n='),-10,10); a.Println;
a:=a.Select((x,i)->i mod 2=0?x+1:x-1).ToArray; a.Println
end.
Пример
n= 10
-9.05843428292239 -4.25451094017108 9.66351874157019 -3.1105665178553 4.8065062215582 -2.02809873597142 4.59844561973514 -4.45959216657076 1.37816560984504 -7.69115956392659
-8.05843428292239 -5.25451094017108 10.6635187415702 -4.1105665178553 5.8065062215582 -3.02809873597142 5.59844561973514 -5.45959216657076 2.37816560984504 -8.69115956392659
0,0
(0 оценок)
Популярные вопросы: Информатика
mutagan25Mark
18.07.2021 14:23
1)как записывается число d13 (16) в восьмеричной системе счисления? 2)как записывается число 474 в шестнадцатиричной системе? подробно ....
salievtrofim20
18.07.2021 14:23
Решить алгоритм при таблицы, где: a: =7; b: =8; c: =8; while a+b 333 do begin c: =c+3; a: =a+c; b: =b-1; end; for c: =1 to 5 do a: =a-c*2; write(a); end....
mexoc
20.08.2022 08:53
мне не с информатикой до отправки осталось 30 минут^_^...
Maguire
14.05.2021 08:13
Чем ты хочешь заниматься на уроке информатики...
ИноК11
26.01.2023 17:43
Робот выполняет 8 операций какое количество информации содержится в каждой такой операции...
itszhamilya1
28.12.2022 12:45
Тихий зимний день березки дороги стоят в снежном наряде застыли сосед сосенки под слоем снега а рядом на сосне снег лежит мелкими комочками кажется что ночью здесь побывал...
vakhram
28.12.2022 12:45
Найдите наименьшее трехзначное число, кратное 19...
ghhgbg
28.12.2022 12:45
Решить по информатике циклы по теореме паскаля. числа от 33 до 555 которые кратны 13...
Yaroslav34364
28.12.2022 12:45
Написать сочинение на казахском языке на тему абай кунанбаев...
TuyaChimitova
28.12.2022 12:45
Каждому ряду семь чисел из них 6 подобраны некоторому признаку найди каждом ряду лишнее число 70,16,34,61,29,52,43....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandomReal(ReadInteger('n='),-10,10); a.Println;
a:=a.Select((x,i)->i mod 2=0?x+1:x-1).ToArray; a.Println
end.
Пример
n= 10
-9.05843428292239 -4.25451094017108 9.66351874157019 -3.1105665178553 4.8065062215582 -2.02809873597142 4.59844561973514 -4.45959216657076 1.37816560984504 -7.69115956392659
-8.05843428292239 -5.25451094017108 10.6635187415702 -4.1105665178553 5.8065062215582 -3.02809873597142 5.59844561973514 -5.45959216657076 2.37816560984504 -8.69115956392659