В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Simochka123
Simochka123
02.12.2021 01:06 •  Информатика

Составьте программу в паскале которая имитирует движения дельфина или кораблика по волнам. или что-то в этом роде.

Ответ:
Milana8211
Milana8211
04.10.2020 21:19
program corablik; uses Graph, Crt; var   grDriver: integer;   grMode: integer;   ErrCode: integer;   x,y,y0,a,b: integer;{a,b-переменные для линии моря, чтоб они не зависели от х,у}  procedure more(a,b:integer); begin moveto(0,y0); setcolor(blue); for a:=0 to 680 do{слева направо рисуем синусоиду синего чвета}   begin   b:=y0-round(sin(a*pi/180)*30);{30-коэффициент масштабирования по оси Х, чем больше, тем волна круче}   lineto(a,b);  end; end;  begin   grDriver := Detect;   InitGraph(grDriver, grMode, '..\BGI');   ErrCode := GraphResult;   y0 := 250;   if ErrCode = grOk then   begin     x:=600;     while x>=0 do{лучше использовать цикл while, можно менять величину шага, что тоже влияет на скорость и частоту смены картинки}      begin       cleardevice;       more(a,b);{рисуем волну}       setcolor(white);{устанавливаем цвет кораблика}       y:=y0-40-round(sin(x*pi/180)*30);{движемся по волне}       MoveTo(x - 40, y + 20);       LineTo(x - 20, y + 40);       LineTo(x + 20, y + 40);       LineTo(x + 40, y + 20);       LineTo(x - 40, y + 20);       MoveTo(x + 15, y + 20);       LineTo(x + 15, y - 40);       LineTo(x - 20, y + 20);       LineTo(x + 15, y + 20);       delay(100); {нормальная скорость, если модули *.TPL не глючные как у Вас,  время должно быть в миллисекундах, а не в каких-нибудь наносекундах}       x:=x-2;{шаг движения}     end;   end   else Writeln('Graphics error: ', GraphErrorMsg(ErrCode));  Settextstyle(0,0,3);{устанавливаем стиль шрифта}  cleardevice;  setcolor(red);  OuttextXY(200,240,'Rejs zavershen!');{выводим надпись}  readln;  CloseGraph; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?