Войти
Регистрация
Спроси ai-bota
В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
Показать больше
Показать меньше
chobanu81p08xbb
21.04.2021 08:41 •
Информатика
"среди чисел a,b,c,d найти сумму целых чисел " составьте программу по этой на pascal abc
Ответ:
supergirll9
04.10.2020 20:42
Var
a,b,c,d:real;
s:integer;
begin
Write('Введите a b c d: '); Read(a,b,c,d);
if frac(a)=0 then s:=Trunc(a) else s:=0;
if frac(b)=0 then s:=s+Trunc(b);
if frac(c)=0 then s:=s+Trunc(c);
if frac(d)=0 then s:=s+Trunc(d);
Writeln('S=',s)
end.
Пример
Введите a b c d: 2.5 6 -3 -1.75
S=3
0,0
(0 оценок)
Популярные вопросы: Информатика
mops14
24.06.2020 21:18
Отличительные интерфейса пользователя...
Nerzul2828818
10.04.2022 12:15
Чем отличается i от i в информатике...
Котик132457
18.10.2021 23:50
Умоляю вас , никак не получается решить! : ( 15 кб = ? байт 256 кб = ? бит 2560 байт = ? мб 2 мб = ? кб подробно с решением....
lisss2005
03.06.2023 01:52
От имени прилагательного свежий образуй и запишиформу множественного числа в творительном падеже....
nastyavix
23.01.2023 04:16
Чем знаменита статуя Зевса??...
danikmy12
07.11.2021 19:27
2. Электр үтігі 220 В желіге қосылған. Үтіктің қыздыру элементінің кедергісі 50 Ом болса, ондағы ток күші қандай?...
Ашеашачочєо
30.12.2022 15:12
Скласти твір на вільну тему з дієприслівниковим зворотом на 15 речень. ів...
stalkerdanil111
30.12.2022 15:12
397. Представьте выражение в виде суммы кубон:а) Х³+ 8;б) 27+а³,...
rmaro82
30.12.2022 15:12
Что такое планктон каков его значение в океане...
лена6ада
30.12.2022 15:12
Опсание состояние человека в новый год...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
a,b,c,d:real;
s:integer;
begin
Write('Введите a b c d: '); Read(a,b,c,d);
if frac(a)=0 then s:=Trunc(a) else s:=0;
if frac(b)=0 then s:=s+Trunc(b);
if frac(c)=0 then s:=s+Trunc(c);
if frac(d)=0 then s:=s+Trunc(d);
Writeln('S=',s)
end.
Пример
Введите a b c d: 2.5 6 -3 -1.75
S=3