В
Все
У
Українська література
Г
Геометрия
Д
Другие предметы
Э
Экономика
Г
География
О
ОБЖ
М
Математика
М
МХК
Х
Химия
Қ
Қазақ тiлi
Л
Литература
У
Українська мова
О
Обществознание
Ф
Физика
А
Английский язык
А
Алгебра
И
История
Б
Беларуская мова
Б
Биология
М
Музыка
П
Право
И
Информатика
П
Психология
В
Видео-ответы
Н
Немецкий язык
Ф
Французский язык
О
Окружающий мир
Р
Русский язык
lololka125
lololka125
07.12.2020 09:11 •  Информатика

Составить программу, которая запрашивает координаты двух точек, а выводит длину отрезка, концами которого эти точки являются, и координаты середины этого отрезка. (блок систему и на языке паскаль)

Ответ:
MiaRia123
MiaRia123
04.10.2020 20:39
Program Programma;
Uses crt;

var xA,xB,yA,yB,D: real;

Begin clrscr;
write('Введите координаты точки A через пробел: ');
readln(xA,yA);
write('Введите координаты точки B через пробел: ');
readln(xB,yB);

d:=sqrt(sqr(xA-xB)+sqr(yA-yB));
writeln;
write('Длина отрезака AB = ',d:0:3)
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?